Unable to upload data

When I uploaded notMNIST_small.mat, neptune told me ‘Connection lost. Retrying…’ all the time. The figure is below:
How do I solve it?
I think it is probably caused by the GFW as I am in China. If I want to set proxy for uploading, how to set it? Thanks much!

1 Like

It is a bug in our code. We are working to fix upload problems on Windows and upload problems in general. In the meantime you can try going into data folder and sending the file from there.

cd ..\data
neptune data upload notMNIST_small.mat
1 Like

Going into data folder is still the same result. By the way, I get the same on Ubuntu. So I think it is caused by the network environment in China… If there is a place to set proxy, it will be better.

1 Like


we’re analyzing the the problem. You might be right that it is a network issue. We’ll try to improve the way Neptune handles a slow network connection. Hopefully there would be no need for a proxy.

We’ll get back to you when we have more information.


1 Like

Hi @loveisp,

We’ve released CLI in version 2.8.2 today (see announcement).
It introduced an improvement in the upload process. Give it a shot :slight_smile:

still the same problem . I can`t upload the data

Hi @yuyang!

Does the problem persist?
If so, could you send me your neptune.log via PM? (It should be in the directory you run the neptune command).