Possible issue with data download, both web and CLI?

I tried to download generated files from storage, but the file seems truncated at about 43 MB no matter through web page or cli.

CLI seems to calculate the correct file size, aligning with what displayed on the web UI, but download finishes at 28%:

Downloading best.torch : 28%|████████▊ | 44.5M/161M [00:29<01:16, 1.51MB/s]

I tried downloading through CLI several times, each time I got a different size around 43 MB.

The web page does not seem to include the total size of the file. I tried to download from web page several times, and again I got a different size but all of them are around 43 MB each time.

Downloading smaller files around several MB seems OK.

Is this expected behavior?


It sounds like a bug on our side, can you point me to the specific file this occurs?

We’ll investigate what happens and get back to You,


@lih We fixed the issue in today’s release. Now you can download bigger files too. :slight_smile: Sorry for inconvenience!