Issue with command line parameters

When I type (as from neptune send documentation):

neptune send --model mlp it does not affect parameters.

(As as side note, it would be nice if was optional, the same way as it is without parameters.)



Hi @pmigdal,

Command line arguments for your code are not treated as Neptune parameters by default. You can both pass a parameter using -p option (neptune send -p model:mlp) or explicitly tell Neptune to treat arguments as parameters by using a special syntax neptune send --model %mlp.

Thanks @Wajcha ! It was not clear from the examples, though.

Though, it this case I guess there should be an error message. Otherwise its confusing.

Anyway, neptune send -p model:mlp does not work (I didn’t type quotation marks), see:

Hi @pmigdal,

It’s definitely a bug with parsing parameters on our side, I’ll look into it and we should have a fix soon

Best regards & Happy Holiday,