Installing with anaconda

Hi all i am installing Neptune-CLI with anaconda.
After installing the necessary packages : pip install -U neptune-cli -I --user

Successfully installed Flask-0.12 GitPython-2.1.10 Jinja2-2.10 MarkupSafe-1.0 Pillow-5.1.0 PyJWT-1.6.4 PyYAML-3.12 Werkzeug-0.14.1 argcomplete-1.9.4 certifi-2018.4.16 chardet-3.0.4 click-6.7 docopt-0.6.2 enum34-1.1.6 future-0.16.0 gitdb2-2.0.3 humanize-0.5.1 idna-2.6 itsdangerous-0.24 kitchen-1.2.5 more-itertools-4.2.0 neptune-cli-2.8.4 oauthlib-2.1.0 pathlib2-2.3.0 psutil-5.4.6 pykwalify-1.5.2 python-dateutil-2.7.3 raven-6.9.0 requests-2.18.4 requests-oauthlib-1.0.0 six-1.11.0 smmap2-2.0.3 terminaltables-2.1.0 tqdm-4.23.4 urllib3-1.22 voluptuous-0.11.1 websocket-client-0.48.0

i run:
neptune login

and i get this error:

‘neptune’ is not recognized as an internal or external command,
operable program or batch file.

What’s going on?

BTW is there a way to upload files to Neptune from the browser instead of suing the CLI? Thanks.


Thanks for reporting this to us,
We will investigate this in the beginning of the week.

For now, can you try running neptune from a new console? It might be possible that your PATH was not updated correctly for you current console after installing.

If that doesn’t help you can search the location of neptune binary and add it manually to your PATH

As for uploading file, currently we don’t support uploading files from the browser, but we’ll add it to our TODO list.

Best Regards,

I tried running Neptune on a new console i still get the same error.

OK i solved it. I added C:\Users\xxxx\AppData\Roaming\Python\Python36\Scripts
to the PATH. (you can find it in you environmental variables)