Can't find my saved models after succeeded run

I have used a base code with an LDA unsupervised algorithm for text clustering and topic detection, then saved the model using "“ldaModel_ko_500pass”) " by gensim module and I can’t find where my saved files for my model so I can download it to my local computer.

The code works well on my local computer and it saves the model on the current directory for the code.

Hi @sharafcode

All data that needs to be persisted should be written to /output directory. After that, you can find them in experiment dashboard in jobs/{jobID}/output directory or download them by neptune data download command.


You can add --backup option to neptune send command to make any file or directory be saved in /experiments/{experimentId}/jobs/{jobId}/backup directory.

I have added backup to ‘neptune send’ and use --backup “/Checkpoints_training” to backup my saved parameters that I have saved it in this directory then after succeeded run, nothing found in the backup dir. !!! I don’t know where’s the error is it from my side or from the server side.


Could you attach ID of your experiment?


ID :: c637b87e-a379-4fba-b620-e7b2327e81f2

It looks like the command you performed was

neptune send --environment base-gpu --worker gcp-gpu-medium --input /uploads/KO_raw_withBODY.csv --backup

instead of

neptune send --environment base-gpu --worker gcp-gpu-medium --input /uploads/KO_raw_withBODY.csv --backup /Checkpoints_training

and there actually is file backuped. Could you verify if this is correct?

I have run another experiment with the comand neptune send --environment base-gpu --worker gcp-gpu-medium --input /uploads/KO_raw_withBODY.csv --backup /Checkpoints_training
, and still can’t find my saved files.


It looks like neptune can’t find /Checkpoints_training file in a root directory.
Are you sure that your code creates /Checkpoints_training in a root dir (and that it starts with a capital C)? If an argument for --backup option starts with /, neptune will search for it in root dir. If your code creates it in a working directory you should skip a slash in a path.